浏览器版本过低提示

2018-7-11    分类: 前端资源

js css 判断 ie 浏览器 版本过低

 

<!--[if lte IE 9]>  <!--包括ie9以及ie9以下浏览器会提示--> 
 <div class="browsertip" id="browsertip"> <i class="ico-warn"></i> 您系统上的IE版本过低,可能会导致某些功能无法正常使用,<a href="http://dl.pconline.com.cn/sort/104.html" target="_blank" title="去升级">去升级IE</a> </div>
<![endif]-->


<!--[if lt IE 9]> <!--ie9以下浏览器会提示不包括ie9--> 
 <div class="browsertip" id="browsertip"> <i class="ico-warn"></i> 您系统上的IE版本过低,可能会导致某些功能无法正常使用,<a href="http://dl.pconline.com.cn/sort/104.html" target="_blank" title="去升级">去升级IE</a> </div>
<![endif]-->

 

css:

/*浏览器版本过低提示*/

.browsertip {
 position: fixed;
 top: 0;
 left: 0;
 width: 100%;
 height: 35px;
 line-height: 35px;
 text-align: center;
 color: #F1F1F1;
 z-index: 20;
 background-color: rgba(0, 0, 0, 0.5);
 background: #000000;
 filter: alpha(opacity=50);
}

.browsertip a {
 color: #fc8412;
}

.browsertip .ico-warn {
 display: inline-block;
 vertical-align: middle;
 width: 25px;
 height: 25px;
 margin-right: 6px;
 position: relative;
 background: url(../img/www/bg.png) no-repeat -342px -4px;
 cursor: pointer;
 background-position: -715px -42px;
}